16v Mini Club Forums  

Go Back   16v Mini Club Forums > Builds > Rover Builds

Reply
 
Thread Tools Display Modes
Old 28-11-2011, 12:00 AM   #16
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

25/11/2011

Well after a lot of head scratching (and a replacement ECU set) here we are! (Sorry about Kyle's cameraman skills!)



The wires not being used have been removed. The rest will need to be fit and tidied up.

Clutch and gears all work. Had a drive up and down my drive. (About 10m!)


AGoaty is offline   Reply With Quote
Old 29-11-2011, 09:43 PM   #17
Add_Gee
Senior Member
 
Add_Gee's Avatar
 
Join Date: Feb 2009
Location: Staffordshire
Posts: 354
Subframe: Watson
CC: 1800
Make: Rover
ECU: Rover
Default

Good write up, some useful info there
Add_Gee is offline   Reply With Quote
Old 30-11-2011, 03:07 PM   #18
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

It has been a lot of work to get this far so it is good to get it running!

The altenator had siezed. This meant the engine would not turn over even though the wiring was correct but I only found this out after jump starting it and all hell being let loose under bonnet! Smoke and screaming from the burning belt (which was brand new).

It was a little scarey driving it for the first time, but it was all ok. The accelerator pedal and cable weren't fitted so could only run it on tickover. It is now moddified and fitted. Brakes also worked fine but do seem to have a lot of travel. Hope this will improve when bedded in.

The wiring nightmare continues. I have pulled it all out now to shorten every wire as it's all about 4 feet too long!
AGoaty is offline   Reply With Quote
Old 20-01-2012, 12:13 AM   #19
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

19/12/2011

Wiring is back in the car and engine runs again. Still got all the lights, etc, etc to wire up but the switches and fuse boxes are in with wires running to each component. Just needs the ends sorting. I've quit today as it's too cold in the garage!

Here's the before and after photo's of the main loom. Third one is what I've cut out of the main loom. There's also more component wiring eg ABS and electric windows, sunroof, which has also been removed.





Disused wires.


Last edited by AGoaty; 10-07-2017 at 08:59 AM.
AGoaty is offline   Reply With Quote
Old 20-01-2012, 12:17 AM   #20
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

13/1/2012

Had a nice quiet Christmas and didn't do any Mini stuff at all. Now it's new year I can continue with Phoenix.

Since fitting the engine and gearbox I have had a serious oil leak from one of the drive shaft seals. I have had to order one from Rimmer brothers as no-one had one locally. This has now been fitted and means that I can drive the Mini.

I've got the wiring in the rear of the car. The washer bottle has had to be put in here like a later injection model would have. Fuel pump and sender wired up properly. The rear Mk2 lights have new rubbers and now work as they should. Boot refitted with number plate light.

Next was the wipers. Had a lot of drama with this, but turned out to be a simple fix.
On a Mini the wipers are fed by 2 power wires through the switch and earthed at the motor. On the Rover the motor is fed with power and the switches go to earth. I thought well it's only a motor, it can run backwards no problem! It did, but would not park at the end of each stroke. So I thought I'd wired it up wrong but after changing it around various ways I found that it was right in the first place and the park switch was faulty. So a new switch has been ordered. I now have wipers that work and have intermittent wipers too!

The next thing is the headlight bowls. Basically the engine / radiator protrude into the area of the bowl. These need to be "adjusted" to fit.
AGoaty is offline   Reply With Quote
Old 29-01-2012, 09:45 PM   #21
Stevee
Member
 
Stevee's Avatar
 
Join Date: Oct 2010
Location: Northamptonshire
Posts: 73
Make: Rover
Default

Looking good keep up the good work
Stevee is offline   Reply With Quote
Old 06-02-2012, 11:31 AM   #22
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

Blooming cold working at this time of year so bobbing in and out to try to keep this moving along.

Got my plastic headlight bowls from the Stafford Mini show last weekend. They have been heated up using the hot air gun and them reformed using a plank of wood to clear the radiator and engine timing cover. I've fitted and wired them up today with a new halogen lamp kit as the sealed beam ones are poor.

Cleaned up the grill and side lights I got from Classic Mini Bits and trial fitted these which seems all good.





Just those silly corners to do next.....

Last edited by AGoaty; 10-07-2017 at 08:59 AM.
AGoaty is offline   Reply With Quote
Old 21-04-2012, 07:27 PM   #23
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

It's been a while since last update so here goes to whats been happening.

A local Mini based shop had an open day to try sell off some of there used Mini stuff. I got most of the parts I needed to finish Phoenix from there for 20!

I got a 2" RC40 back box
Top dash rail with vents and ashtray
Battery clamp
Various bolts and rubber mounts
An alloy wheel for a spare as it's the same as mine.

I hated the loudness of the exhaust which Lee had fitted to my car. It only used the middle box from the Rover as a back box and was very loud. So I've cut the long pipe and welded it back so the box is now in the middle and then fitted the RC40 to the end. It has a nice chrome side exit pipe and is no louder than a normal Mini but has a nice deep note to it.

I've been trying to get this ready for the road so needed to finish the front panel. This has been a pain and still not happy about it but don't know how to improve it. Basically it was rotten so decided to cut the bottom off and just weld sheet along it to create a front apron. Then I had to make some spacer pieces to bolt it to the front subframe. It works ok but not the most attractive front apron.



Also took this which is my other Mini and my mates in background!



I'm trying to get the inside finished now. I have trial fitted the dash rails and have to mount the speedo onto a bracket from an 1980's Mini. I got some carpet from Stafford Mini show and have fitted them.

Hopefully not long now....

Last edited by AGoaty; 10-07-2017 at 09:00 AM.
AGoaty is offline   Reply With Quote
Old 22-04-2012, 09:02 AM   #24
matt
Senior Member
 
matt's Avatar
 
Join Date: Jan 2008
Location: Birmingham
Posts: 1,639
Subframe: Home Made
CC: 1.8VVC
Make: Rover
ECU: Mems 3 Z&F
Default

Looks good this. The vvc always makes a nice exhaust note but hard to keep them quiet. Its a shame how the frame doesn't fit under the clubman front. Did you think about making the sub frame shorter?
__________________
13.5 @ 101mph standard VVC engine
Rover no show and all go!!!!!
matt is offline   Reply With Quote
Old 22-04-2012, 04:10 PM   #25
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

I have been disappointed in Watsons who never even mentioned it when I talked about fitting it. I did consider cutting the frame but when you spend 800 buying a kit to fit it, I didn't want to ruin it! I wish I'd just made my own now....
AGoaty is offline   Reply With Quote
Old 28-04-2012, 07:50 PM   #26
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

A bit more progress.

It's now the colour I want but will need another coat but this isn't bad for painting using a roller and paint brush!





Dash is in with the new switch panel finished. Inside I've cut the carpet but then removed it to paint the inside. I'll take some photo's when it's all fitted.

Wheel arches are not a good fit. The fronts are ok but the backs are nowhere near! That's Huddersfield spares for you....

Last edited by AGoaty; 10-07-2017 at 09:00 AM.
AGoaty is offline   Reply With Quote
Old 03-05-2012, 06:29 AM   #27
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

Aches are on but had to bend them and hold them in place with the screws. They're only just wide enough.

Bumpers, sidelights and indicators fitted. Grill painted and fit.

Front isn't too bad now. Might just get a finishing strip along bottom of apron.



Interior next.

Last edited by AGoaty; 10-07-2017 at 09:00 AM.
AGoaty is offline   Reply With Quote
Old 03-05-2012, 09:13 AM   #28
gadget555
Senior Member
 
Join Date: Jan 2011
Location: Strichen Aberdeenshire
Posts: 1,316
Subframe: Watson
CC: 1800
Make: Rover
ECU: K maps 160 Race
Default

looking good great progress
gadget555 is offline   Reply With Quote
Old 19-05-2012, 04:05 PM   #29
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,829
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

Interior is fitted but need the dash finishing.









I don't know if anyone else dare do this but this is the cost of this project.



It's needed a track rod end for MOT, tax is free and I've just been quoted 368 to insure it.

This has been hours and hours of "fun". Lets hope it's reliable now!

Last edited by AGoaty; 10-07-2017 at 09:00 AM.
AGoaty is offline   Reply With Quote
Old 20-05-2012, 07:16 AM   #30
chabbly vvc
Senior Member
 
chabbly vvc's Avatar
 
Join Date: May 2011
Location: Bristol
Posts: 498
Subframe: Allspeed
CC: 1800
Make: Rover
ECU: standard
Default

Well done buddy car looks amazing!! Love the colour!! As 4 the total price of your build all I can say wish mine was gunna look as low as that when finished :s
chabbly vvc is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:19 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.