16v Mini Club Forums  

Go Back   16v Mini Club Forums > Builds > Suzuki Builds

Reply
 
Thread Tools Display Modes
Old 21-08-2018, 06:39 AM   #646
Marcus Nordblom
Senior Member
 
Marcus Nordblom's Avatar
 
Join Date: Oct 2003
Location: Playboy mansion
Posts: 2,409
Subframe: Allspeed
CC: 1298
Make: Suzuki
ECU: 40mm mikuni rs
Send a message via MSN to Marcus Nordblom
Default

Quote:
Originally Posted by cedric998 View Post
curious to know what broke in your engine. did it "go" at high rews or was it more or less normal use ??

brgds
chris
unsure what caused it, think its the rod bearings 2/3 cylinder, pistons are loose up/down a couple of mm……engine sounded like a maracas orchestra. Think it happened when i was on track the last time, maybe something with oil supply or aggressive downshifting
Marcus Nordblom is offline   Reply With Quote
Old 22-08-2018, 09:50 AM   #647
DVO
Senior Member
 
DVO's Avatar
 
Join Date: Oct 2009
Location: Noordwijkerhout, Netherlands
Posts: 520
Subframe: Home Made
CC: 1298
Make: Suzuki
ECU: Chipped
Default

Almost sounds like what I had last time when I broke the engine, suddenly a big rattle. Still do not know what happened, but also suspect some bearing (s) gave way in the bottom end.

Dennis
DVO is offline   Reply With Quote
Old 22-08-2018, 09:01 PM   #648
Marcus Nordblom
Senior Member
 
Marcus Nordblom's Avatar
 
Join Date: Oct 2003
Location: Playboy mansion
Posts: 2,409
Subframe: Allspeed
CC: 1298
Make: Suzuki
ECU: 40mm mikuni rs
Send a message via MSN to Marcus Nordblom
Default

I thought the rods should go before the bearings, maybe something with insufficient oil supply when engine is a little less tilted than original

Mu headgasket Almost cover the round rear oil drain hole close to 1# cylinder, i guess that is the way it should be?
Can take a pic


Skickat från min iPhone med Tapatalk
Marcus Nordblom is offline   Reply With Quote
Old 29-08-2018, 05:29 PM   #649
Marcus Nordblom
Senior Member
 
Marcus Nordblom's Avatar
 
Join Date: Oct 2003
Location: Playboy mansion
Posts: 2,409
Subframe: Allspeed
CC: 1298
Make: Suzuki
ECU: 40mm mikuni rs
Send a message via MSN to Marcus Nordblom
Default

Fittings my LSD after sitting 9 years on the shelf was a bit eager and manage to dremmel 2 holes in the casing when making room for it (mk1 box)

Fingers crossed 🤞 that the box will function after my tear down




Skickat från min iPhone med Tapatalk
Marcus Nordblom is offline   Reply With Quote
Old 09-10-2018, 06:57 PM   #650
Marcus Nordblom
Senior Member
 
Marcus Nordblom's Avatar
 
Join Date: Oct 2003
Location: Playboy mansion
Posts: 2,409
Subframe: Allspeed
CC: 1298
Make: Suzuki
ECU: 40mm mikuni rs
Send a message via MSN to Marcus Nordblom
Default

Well, the box did function after my teardown but the diff gave up on track this weekend, have fitted another gearbox now unsure what happened to it, it didn’t feel smooth to start with a lot of mechanical kind of gear shatter when turning, have to take it apart when I have some om spare time



Skickat från min iPhone med Tapatalk
Marcus Nordblom is offline   Reply With Quote
Old 16-10-2018, 09:42 PM   #651
Marcus Nordblom
Senior Member
 
Marcus Nordblom's Avatar
 
Join Date: Oct 2003
Location: Playboy mansion
Posts: 2,409
Subframe: Allspeed
CC: 1298
Make: Suzuki
ECU: 40mm mikuni rs
Send a message via MSN to Marcus Nordblom
Default

Took my license this weekendcar did very well, but must build a new linkage, current one kind of lock up when shifting high up in the powerband
Very impressed with my race coils, I was going over curbs like F1 haha




Skickat från min iPhone med Tapatalk
Marcus Nordblom is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 12:36 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.