16v Mini Club Forums  

Go Back   16v Mini Club Forums > Builds > Rover Builds

Reply
 
Thread Tools Display Modes
Old 13-12-2017, 08:55 PM   #361
richie08
Senior Member
 
richie08's Avatar
 
Join Date: Jun 2008
Location: Ayrshire, Scotland
Posts: 749
Subframe: Other
CC: 1396
Make: Rover
ECU: Rover mems
Default

Cheers guys

Straight back in the garage seeing as its pouring down in Scotland all day

Sent from my SM-G930F using Tapatalk
richie08 is offline   Reply With Quote
Old 14-12-2017, 04:07 PM   #362
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,535
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

Quote:
Originally Posted by richie08 View Post
Clean pass with no advisories
Great stuff!
__________________
If tha does owt fo nowt, olas do it fo this 'en.
AGoaty is offline   Reply With Quote
Old 17-12-2017, 09:08 PM   #363
richie08
Senior Member
 
richie08's Avatar
 
Join Date: Jun 2008
Location: Ayrshire, Scotland
Posts: 749
Subframe: Other
CC: 1396
Make: Rover
ECU: Rover mems
Default

Had it out today to put some miles on it. Running wonderfully. Haven't taken it above 4k rpm, and not taken it to WOT, however it is stupendously quick.

Has a huge surge of power at 3k rpm and either throws you in to your seat or lights the wheels up. And thats going light on the throttle.

Only a few small bugs identified. The speedo has stopped working, and the front o/s indicator has stopped. Both likely to be simple connection issues on the rebuild. Should be an easy fix.

What a hoot, though!!

Sent from my SM-G930F using Tapatalk
richie08 is offline   Reply With Quote
Old 17-12-2017, 09:12 PM   #364
gadget555
Senior Member
 
Join Date: Jan 2011
Location: Strichen Aberdeenshire
Posts: 1,114
Subframe: Watson
CC: 1800
Make: Rover
ECU: K maps 160 Race
Default

Good man for tearing up the roads of Ayrshire.
gadget555 is online now   Reply With Quote
Old 17-12-2017, 09:15 PM   #365
richie08
Senior Member
 
richie08's Avatar
 
Join Date: Jun 2008
Location: Ayrshire, Scotland
Posts: 749
Subframe: Other
CC: 1396
Make: Rover
ECU: Rover mems
Default

Quote:
Originally Posted by gadget555 View Post
Good man for tearing up the roads of Ayrshire.
Someone has to do it!!

Sent from my SM-G930F using Tapatalk
richie08 is offline   Reply With Quote
Old 17-12-2017, 11:29 PM   #366
ardonfast
Senior Member
 
ardonfast's Avatar
 
Join Date: Oct 2011
Location: dunkeswell airfeald devon
Posts: 7,315
Subframe: AMT
CC: 2000
Make: Vauxhall
ECU: dizzy/webers
Default

well done richie, hoot! lol,weard words you jocks have lol,
price of booze gone up? exspenceive mot man gift lol,
are you still selling now you find Shit nappie love again
__________________
"yuck ,more like a 3 r2"
http://www.youtube.com/watch?feature...&v=tb261HwQNDQ
SAY WHAT YOU BELEVE,,BELEVE WHAT YOU LIKE,
http://www.youtube.com/watch?feature...&v=3JhaTwP7uuk
ardonfast is offline   Reply With Quote
Old 18-12-2017, 10:10 AM   #367
richie08
Senior Member
 
richie08's Avatar
 
Join Date: Jun 2008
Location: Ayrshire, Scotland
Posts: 749
Subframe: Other
CC: 1396
Make: Rover
ECU: Rover mems
Default

Quote:
Originally Posted by ardonfast View Post
well done richie, hoot! lol,weard words you jocks have lol,
price of booze gone up? exspenceive mot man gift lol,
are you still selling now you find Shit nappie love again
Haha, didn't even think that was a scots word!

Booze still affordable for now

Not actively selling it, enjoying it for now. But still got a member on here interested in it

Sent from my SM-G930F using Tapatalk
richie08 is offline   Reply With Quote
Old 15-01-2018, 10:27 PM   #368
richie08
Senior Member
 
richie08's Avatar
 
Join Date: Jun 2008
Location: Ayrshire, Scotland
Posts: 749
Subframe: Other
CC: 1396
Make: Rover
ECU: Rover mems
Default

Been using this occasionally just to run the new engine in, going good so far.

Chasing an intermittent issue with the speedometer, otherwise no faults other than a blown indicator bulb.

Gave it a snowfoam bath yesterday too

Sent from my SM-G930F using Tapatalk
richie08 is offline   Reply With Quote
Old 15-01-2018, 11:02 PM   #369
niannorth
Member
 
Join Date: Apr 2016
Location: Northumberland
Posts: 55
Default

Quote:
Originally Posted by richie08 View Post
Been using this occasionally just to run the new engine in, going good so far.

Chasing an intermittent issue with the speedometer, otherwise no faults other than a blown indicator bulb.

Gave it a snowfoam bath yesterday too

Sent from my SM-G930F using Tapatalk
Looks great, bit cold for washing cars isn't it.



Sent from my SM-G950F using Tapatalk
niannorth is offline   Reply With Quote
Old 16-01-2018, 09:10 PM   #370
richie08
Senior Member
 
richie08's Avatar
 
Join Date: Jun 2008
Location: Ayrshire, Scotland
Posts: 749
Subframe: Other
CC: 1396
Make: Rover
ECU: Rover mems
Default

Quote:
Originally Posted by niannorth View Post
Looks great, bit cold for washing cars isn't it.



Sent from my SM-G950F using Tapatalk
Aye you're right - baltic!

Sent from my SM-G930F using Tapatalk
richie08 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 05:59 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.