16v Mini Club Forums  

Go Back   16v Mini Club Forums > Builds > Rover Builds

Reply
 
Thread Tools Display Modes
Old 28-09-2016, 11:04 AM   #1
Bigredmini94
Member
 
Bigredmini94's Avatar
 
Join Date: Jun 2014
Location: Kent
Posts: 53
Subframe: Allspeed
CC: 1800 t
Make: Rover
ECU: Standard
Default 1000cc TO 1800cc turbo :)

Sorry for leaving it so long but i think its about time i do a build thread for mini.
Ive still got bits left to do but its nearly there the build so far :

Watsons front subframe
6 point cage
Mg zt t engine standard turbo
K maps ecu
Clubman front fibreglass
Perspex windows
Rear mount radiator
Fibreglass doors / rear valance
Koso digi dash
C6 gearbox (need lsd )
Fse rising rate fuel regulator
Walbro fuel pump
Rose joint engine steadies

Theres lots of other little bits but just a quick run down, had lots of grief doing bits but thanks to you guys using your build thread etc its helped a hell of a lot .
Its a big shock 2 the system for a first build not knowing how to get round things and you feel like giveing up but the first drive is the dogs bollocks lol .
Ill try to upload some photos for you all 2 look at.

Thanks lewis
Bigredmini94 is online now   Reply With Quote
Old 28-09-2016, 11:23 AM   #2
Bigredmini94
Member
 
Bigredmini94's Avatar
 
Join Date: Jun 2014
Location: Kent
Posts: 53
Subframe: Allspeed
CC: 1800 t
Make: Rover
ECU: Standard
Default

Haveing problems loading the photos ill set up a photo bucket account but a little walk round of the car so far .



Bigredmini94 is online now   Reply With Quote
Old 28-09-2016, 03:21 PM   #3
InstantCustard
Senior Member
 
InstantCustard's Avatar
 
Join Date: Sep 2010
Location: Whitworth, Lancashire
Posts: 5,820
Subframe: Home Made
CC: 1.8
Make: Rover
ECU: Emerald K6
Default

Heated passenger seat, nice!
Build looks good, interesting how you have done the rad in the boot.


Sent from my iPhone using Tapatalk
__________________
Quote:
Originally Posted by Burnard View Post
couldnt be bothered to stretch that far to pull it out.
Quote:
Originally Posted by ardonfast View Post
Haz obviously don't like custard , my Mrs spits it out to!
I love it
InstantCustard is offline   Reply With Quote
Old 28-09-2016, 03:50 PM   #4
Chris16v
Senior Member
 
Join Date: May 2016
Location: Norfolk
Posts: 531
Subframe: Home Made
CC: 1.8 t
Make: Rover
ECU: Emerald K6
Default

I have near identical cooling pipes under my passenger seat with my rear mount radiator and it does get very hot in traffic in the cabin
Chris16v is offline   Reply With Quote
Old 28-09-2016, 06:32 PM   #5
uksnowman
Junior Member
 
Join Date: Mar 2014
Posts: 25
Default

it sounds savage. looking forward to seeing the build photos
uksnowman is offline   Reply With Quote
Old 22-04-2018, 04:41 PM   #6
Bigredmini94
Member
 
Bigredmini94's Avatar
 
Join Date: Jun 2014
Location: Kent
Posts: 53
Subframe: Allspeed
CC: 1800 t
Make: Rover
ECU: Standard
Default

Haven't touched this much since last year ... I also keep for getting to do a build thread
I've changed to an allspeed frame and painted the car and put rad up front my workmanship isn't as good as a lot of people on here but its practical
Here's as it stands .....

Sent from my ONEPLUS A5010 using Tapatalk
Bigredmini94 is online now   Reply With Quote
Old 24-04-2018, 03:44 PM   #7
AGoaty
Senior Member
 
AGoaty's Avatar
 
Join Date: Oct 2008
Location: Keighley, West Yorkshire
Posts: 2,818
Subframe: Watson
CC: 1796
Make: Rover
ECU: Standard
Default

Any reason for changing the subframe? Seems funny as Charly has swapped from Allspeed to Watson's but he was snapping driveshafts like twigs! On that note, what driveshafts are you using?

What happened to the front cross member? Has it disappeared?
__________________
If tha does owt fo nowt, olas do it fo this 'en.
AGoaty is offline   Reply With Quote
Old 24-04-2018, 03:52 PM   #8
Bigredmini94
Member
 
Bigredmini94's Avatar
 
Join Date: Jun 2014
Location: Kent
Posts: 53
Subframe: Allspeed
CC: 1800 t
Make: Rover
ECU: Standard
Default

Quote:
Originally Posted by AGoaty View Post
Any reason for changing the subframe? Seems funny as Charly has swapped from Allspeed to Watson's but he was snapping driveshafts like twigs! On that note, what driveshafts are you using?

What happened to the front cross member? Has it disappeared?
It's was mainly the suspension set up I just didn't like the feel of it still got the frame in case have to go back .... the wheel options was quite slim it may be worse it might be better will not know till I've tried . Shafts are sleeved and welded not running as much hp as his 1.. hd outer CV joints , the front cross is in the shed dw I haven't forgot to put it on .

Sent from my ONEPLUS A5010 using Tapatalk
Bigredmini94 is online now   Reply With Quote
Old 30-04-2018, 06:01 AM   #9
InstantCustard
Senior Member
 
InstantCustard's Avatar
 
Join Date: Sep 2010
Location: Whitworth, Lancashire
Posts: 5,820
Subframe: Home Made
CC: 1.8
Make: Rover
ECU: Emerald K6
Default

Charly was snapping them at the Mini outer hub end where the splines start, itís a weak point.
If your running the HD CVís then you should be ok.


Sent from my iPhone using Tapatalk
__________________
Quote:
Originally Posted by Burnard View Post
couldnt be bothered to stretch that far to pull it out.
Quote:
Originally Posted by ardonfast View Post
Haz obviously don't like custard , my Mrs spits it out to!
I love it
InstantCustard is offline   Reply With Quote
Old 03-06-2018, 07:05 AM   #10
Bigredmini94
Member
 
Bigredmini94's Avatar
 
Join Date: Jun 2014
Location: Kent
Posts: 53
Subframe: Allspeed
CC: 1800 t
Make: Rover
ECU: Standard
Default

Took the the car for a test drive last night excluding a steering issue, i need the alignment done everything was good ... Except I don't know if the mini rads will be up to the job only went round the block and it's sitting around 100 is this right ? I couldn't really see what it does on a stretch long bit of road couldn't go far with it ... But here's some photos .
Think the quickshifts best thing I've changed on it so far
I love get a couple of the inside later ..

Sent from my ONEPLUS A5010 using Tapatalk
Bigredmini94 is online now   Reply With Quote
Old 03-06-2018, 07:39 AM   #11
InstantCustard
Senior Member
 
InstantCustard's Avatar
 
Join Date: Sep 2010
Location: Whitworth, Lancashire
Posts: 5,820
Subframe: Home Made
CC: 1.8
Make: Rover
ECU: Emerald K6
Default

On the standard car the fan doesnít kick in until 104 so 100 is ok, ideally normal running temps would be in the low 90ís.
The Mini rad will be fine, there are a couple of things you can do if your concerned, first of all you can try fitting a NEW expansion tank cap to make sure the system is pressurised,if that doesnít work then I would fit an 82degree thermostat which will open earlier and keep temps lower.


Sent from my iPhone using Tapatalk
__________________
Quote:
Originally Posted by Burnard View Post
couldnt be bothered to stretch that far to pull it out.
Quote:
Originally Posted by ardonfast View Post
Haz obviously don't like custard , my Mrs spits it out to!
I love it
InstantCustard is offline   Reply With Quote
Old 09-06-2018, 04:47 PM   #12
Bigredmini94
Member
 
Bigredmini94's Avatar
 
Join Date: Jun 2014
Location: Kent
Posts: 53
Subframe: Allspeed
CC: 1800 t
Make: Rover
ECU: Standard
Default

https://youtu.be/hQ08fMpAQQA

Took the car for geometry today i didn't realise got slight play in inner tie rod on nearside does anyone know if you can replace just the arm ?
Settings as follows I explained it's just track car and asked what he recommends so we went with this obviously it's down to my feed back but car felt good .
Caster 5 degree
2.5 degree camber
And slight toe in 5 minutes, we tryed parallel toe but car didn't want to go straight when I tested it it sort of fought it's self, still struggle a little but the slight toe in has helped.


Sent from my ONEPLUS A5010 using Tapatalk
Bigredmini94 is online now   Reply With Quote
Old 09-06-2018, 07:48 PM   #13
Chris16v
Senior Member
 
Join Date: May 2016
Location: Norfolk
Posts: 531
Subframe: Home Made
CC: 1.8 t
Make: Rover
ECU: Emerald K6
Default

Well done... Can I hear a slight misfire in the video?
Chris16v is offline   Reply With Quote
Old 09-06-2018, 08:21 PM   #14
Bigredmini94
Member
 
Bigredmini94's Avatar
 
Join Date: Jun 2014
Location: Kent
Posts: 53
Subframe: Allspeed
CC: 1800 t
Make: Rover
ECU: Standard
Default

Quote:
Originally Posted by Chris16v View Post
Well done... Can I hear a slight misfire in the video?
It's not a misfire it's me letting off a little then back on power can only really get the power down and keep it completely straight when tyres are really warmed up but still get slight wheel spin every now and then still got a open diff atm tho .

Sent from my ONEPLUS A5010 using Tapatalk
Bigredmini94 is online now   Reply With Quote
Old 09-06-2018, 10:46 PM   #15
GEORDIE SP1
Senior Member
 
GEORDIE SP1's Avatar
 
Join Date: Jun 2011
Location: Northern Ireland
Posts: 222
Subframe: Allspeed
CC: 1800
Make: Honda
ECU: Standard
Default 1000cc TO 1800cc turbo 😊

You can adjust inner steering arm, take boot off, locking ring behind steering arm ball joint, release the locking tabs screw the inner ring back a bit the screw the ball joint cup up to it
Donít leave it to tight
Tighten the ring against the joint again and tap locking tabs back in. Thatís if itís a mini rack ??


Sent from my iPhone using Tapatalk
GEORDIE SP1 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 07:09 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.