16v Mini Club Forums  

Go Back   16v Mini Club Forums > General Public Area > Honda Chat

Reply
 
Thread Tools Display Modes
Old 07-03-2018, 03:38 AM   #1
jemo
Junior Member
 
Join Date: Jun 2008
Location: Dallas, Texas USA
Posts: 28
Default D15B idle issues

I've read several threads about idle issues on the D series and checked some things but not having any luck. My car starts up instantly and runs good, probably idles a little high and once it warms up the idle dips every few seconds, runs good, dips, runs good, dips...

I checked for vacuum leaks and can't find any. I flushed the coolant and bled all the air out. There are no check engine lights. There's a huge car show this weekend so really wanna get it running right in the next few days. I'd really appreciate any help.

Jeff
jemo is offline   Reply With Quote
Old 08-03-2018, 04:57 AM   #2
Bennjaminozhonda
Senior Member
 
Join Date: Apr 2013
Posts: 210
Subframe: Allspeed
Default

Try cleaning out and or replacing the FITV and ICAV located on the throttle body and back of the inlet manifold respectively.
These gunk up and can play with the base idle when warmed up
Bennjaminozhonda is offline   Reply With Quote
Old 11-03-2018, 11:47 PM   #3
jemo
Junior Member
 
Join Date: Jun 2008
Location: Dallas, Texas USA
Posts: 28
Default

Thanks Benjamin. Sorry I haven't been on the forum a few days, I've been tinkering with the car and took it to a car show. Seems like the idle issue went away tho. It hasn't been doing it this weekend. Maybe it just needed to be run after sitting for close to 10 years?
jemo is offline   Reply With Quote
Old 12-03-2018, 09:18 AM   #4
Bennjaminozhonda
Senior Member
 
Join Date: Apr 2013
Posts: 210
Subframe: Allspeed
Default

The gunk sitting in said bits hopefully got cleared out. Get out there and give her a good revving
Bennjaminozhonda is offline   Reply With Quote
Old 21-03-2018, 07:52 PM   #5
jemo
Junior Member
 
Join Date: Jun 2008
Location: Dallas, Texas USA
Posts: 28
Default

This resolved itself...just needed to be driven a bit.
jemo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:40 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.