16v Mini Club Forums  

Go Back   16v Mini Club Forums > General Public Area > Rover Chat

Reply
 
Thread Tools Display Modes
Old 21-05-2018, 11:51 AM   #1
Cliff Pountney
Member
 
Join Date: Jan 2015
Posts: 39
Default PG1 inner CV joint heat issues?

Gents,

Do any of you guys running Rover K series engines have experience of problems with the RHS inner CV joint boot. It's directly above the exhaust. With the standard Rover system it has no heat shielding but the 4-2-1 manifold I have made brings the exhaust much closer to the CV boot. The pipes are wrapped and the distance from the CV boot to the wrap is a shade over 8mm.

I'm guess some people on here must be in a similar position with either a 4-2-1 or a big bore single pipe from a turbo.



I think I will add a small fan and some ducting to cool the boot and the shift linkages. What other fixes are possible? Is there an off the shelf equal length driveshaft set up for a Rover K series with a PG1 box? Or is it necessary to modify one from another PG1 installation?

Just to give you some context this is all set in the back of a popular Rootes group car and not Mini. Think MGF in Hillman Imp and that's about it.

Your experiences and knowledge would be great.

Thanks,

Cliff
Cliff Pountney is offline   Reply With Quote
Old 21-05-2018, 12:10 PM   #2
gazwad
Senior Member
 
gazwad's Avatar
 
Join Date: Sep 2006
Location: northampton
Posts: 1,966
Subframe: Home Made
CC: 1796
Make: Rover
ECU: standard
Default

the boot should be fine like that, my exhaust used to run as close as that and did cause a problem with the boot failing but after wrapping it i never had another fail.
gazwad is offline   Reply With Quote
Old 21-05-2018, 08:00 PM   #3
Chris16v
Senior Member
 
Join Date: May 2016
Location: Norfolk
Posts: 531
Subframe: Home Made
CC: 1.8 t
Make: Rover
ECU: Emerald K6
Default

I have not had any issues when in VVC form then Turbo form with a 3" downpipe, Both heat wrapped past that point I will say.

Not aware of a direct fit equal length shaft. I do have the 2 piece driveshaft from a MG ZT that bolts to the block fine, but not at a suitable angle for the PG1 gearbox. Still trying to work out my plan for that
Chris16v is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 11:34 AM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.