16v Mini Club Forums  

Go Back   16v Mini Club Forums > Builds > Other Mini Builds

Reply
 
Thread Tools Display Modes
Old 05-01-2017, 03:47 AM   #1
minicoon
Junior Member
 
Join Date: May 2016
Posts: 5
Default BMW K1200RS TPS Problems

Hi,

I am having some trouble calibrating the TPS in my Microsquirt EFI for a K1200RS conversion.

The computer is looking for an upper and lower resistance level which is different from the signal that the 4 pin TPS is giving and hence giving a screwy output.
has anyone else seen this problem or heard of a fix for it?

Thanks
Mark
minicoon is offline   Reply With Quote
Old 05-01-2017, 08:05 AM   #2
MattG
Administrator
 
MattG's Avatar
 
Join Date: Sep 2003
Location: West Sussex,UK
Posts: 7,291
Subframe: Allspeed
CC: 2000
Make: Vauxhall
ECU: Megasquirt
Default

yep , same issue , i swapped to a 3 pin ,

basically the bike TPS has two tracks, one gives good detail 0 to 5v from 0 to 25% ( guessing figures ) and the 2n gives good detail from 25% to 100% , 0 to 5v , so maybe there is a good / nice way to wire it up , but i fitted a 3 pin TPS from a vauxhall in the end

inside BMW :



and the adaptor plate my dad made / adaptor pin :

__________________
Mini Restoration on YouTube
VW camper in storage , Red hot , www.16vmini.co.uk www.jetblackmini.co.uk
Dad's Building K1100 : bmw.16vmini.co.uk , donate to club running costs : paypal@16vminiclub.com
MattG is offline   Reply With Quote
Old 05-01-2017, 10:43 PM   #3
hydrolastic
Junior Member
 
Join Date: May 2012
Posts: 8
Default

Yes, had the same problem and swapped to a buick one on a throttle body. http://www.ebay.com/itm/Throttle-Bod...1S~4R5&vxp=mtr Also changed the crank sensor to a volvo one cause i just could not get the
fiat one to work. The crank trigger wheel was also evened out (Symmetrical teeth) The rest of the sensors were GM i think except the OX sensor but there i used the Bosch which also ran the AF gauge. The Megasquirt system also needs a special coil since it is lacking some kind of code to read a standard coil turns out a coil from a new beetle was a plug in because it is compatible with the megasquirt. Since the conversion the sensors have been trouble free and it fires up on the third revolution of the engine everytime. Hydro
hydrolastic is offline   Reply With Quote
Old 07-02-2017, 12:28 AM   #4
mic
Senior Member
 
Join Date: Nov 2006
Location: Maidenhead
Posts: 411
Send a message via MSN to mic
Default

Can I ask why you (or anyone else it seems) don't use the original coil packs from the BMW engine?
mic is offline   Reply With Quote
Old 07-02-2017, 07:40 AM   #5
MattG
Administrator
 
MattG's Avatar
 
Join Date: Sep 2003
Location: West Sussex,UK
Posts: 7,291
Subframe: Allspeed
CC: 2000
Make: Vauxhall
ECU: Megasquirt
Default

1) I did not get them with my head
2) i know MS works perfect with the coil pack i head , so saved lots of experimenting time trying to get it to work with other coil packs.
__________________
Mini Restoration on YouTube
VW camper in storage , Red hot , www.16vmini.co.uk www.jetblackmini.co.uk
Dad's Building K1100 : bmw.16vmini.co.uk , donate to club running costs : paypal@16vminiclub.com
MattG is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:11 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.